Cisco CCST Networking Certification FAQs

CCST Networking exam is 50 minutes in duration with approximately 40-50 questions. This is an entry-level networking certification and gateway to CCNA exam. Students have the option of either in-person or online testing.

Cisco Certified Support Technician (CCST) Networking certification prepares you for entry-level roles such as Network Support Technician, Entry-level Help Desk Technician, or IT Support Specialist. You will learn how networks operate, including the devices, media, and protocols that enable network communication.

Develop key skills so you can perform basic troubleshooting, using effective methodologies and help desk best practices. This certification is well-suited for non-technical roles as well such as IT Project Managers. Learn the networking lingo for data center and cloud implementation.

Cisco Exam NumberCCST 100-150
Number of Questions40-50
Duration50 minutes
Pass Score70%
Cost125 USD
Types of Questionmultiple choice, drag and drop

1.0 Standards and Concepts

    • Identify the fundamental conceptual building blocks of networks.
      TCP/IP model, OSI model, frames and packets, addressing
    • Differentiate between bandwidth and throughput.
      Latency, delay, speed test vs. Iperf
    • Differentiate between LAN, WAN, MAN, CAN, PAN, and WLAN.
      Identify and illustrate common physical and logical network topologies.
    • Compare and contrast cloud and on-premises applications and services.
      Public, private, hybrid, SaaS, PaaS, IaaS, remote work/hybrid work
    • Describe common network applications and protocols.
      TCP vs. UDP, FTP, SFTP, TFTP, HTTP, HTTPS, DHCP, DNS, ICMP, NTP

    2.0 Addressing and Subnet Formats

      • Compare and contrast private addresses and public addresses.
        Address classes, NAT concepts
      • Identify IPv4 addresses and subnet formats.
        Subnet concepts, Subnet Calculator, slash notation, and subnet mask; broadcast domain
      • Identify IPv6 addresses and prefix formats.
        Types of addresses, prefix concepts

      3.0 Endpoints and Media Types

        • Identify cables and connectors commonly used in local area networks.
          Cable types: fiber, copper, twisted pair; Connector types: coax, RJ-45, RJ-11, fiber
        • Differentiate between Wi-Fi, cellular, and wired network technologies.
          Copper, including sources of interference; fiber; wireless, including 802.11 (unlicensed, 2.4GHz, 5GHz, 6GHz), cellular (licensed), sources of interference
        • Describe endpoint devices.
          Internet of Things (IoT) devices, computers, mobile devices, IP Phone, printer, server
        • Demonstrate how to set up and check network connectivity on Windows, Linux
          Networking utilities on Windows, Linux
          Run troubleshooting commands; wireless client settings (SSID, authentication, WPA mode)

        4.0 Infrastructure

          • Identify the status lights on a Cisco device when given instruction by an engineer.
            Link light color and status (blinking or solid)
          • Use a network diagram provided by an engineer to attach the appropriate cables.
            Patch cables, switches and routers, small topologies, power, rack layout
          • Identify the various ports on network devices.
            Console port, serial port, fiber port, Ethernet ports, SFPs, USB port, PoE
          • Explain basic routing concepts.
            Default gateway, layer 2 vs. layer 3 switches, local network vs. remote network, arp
          • Explain basic switching concepts.
            MAC address tables, MAC address filtering, VLAN

          5.0 Diagnosing Problems

            • Demonstrate effective troubleshooting methodologies and help desk best practices, including ticketing, documentation, and information gathering.
              Policies and procedures, accurate and complete documentation, prioritization
            • Perform a packet capture with Wireshark and save it to a file.
              Purpose of using a packet analyzer, saving and opening a .pcap file
            • Run basic diagnostic commands and interpret the results.
              ping, ipconfig/ifconfig/ip, tracert/traceroute, nslookup; how firewalls influence the result
            • Differentiate between different ways to access and collect data about network devices.
              Remote access (RDP, SSH, telnet), VPN, terminal emulators, Console, Network Management Systems, cloud-managed network (Meraki), scripts
            • Run basic show commands on a Cisco network device.
              show run, show cdp neighbors, show ip interface brief, show ip route, show version, show inventory, show switch, show mac address-table, show interface, show interface status; privilege levels; command help and auto-complete

            6.0 Security

              • Describe how firewalls operate to filter traffic.
                Firewalls (blocked ports and protocols); rules deny or permit access
              • Describe foundational security concepts.
                Confidentiality, integrity, and availability (CIA); authentication, authorization, and accounting (AAA); Multifactor Authentication (MFA); encryption, certificates, and password complexity; identity stores/databases (Active Directory); threats and vulnerabilities; spam, phishing, malware, and denial of service
              • Configure basic wireless security on a home router (WPA).
                WPA, WPA2, WPA3; Personal and Enterprise; wireless security concepts

              Free Course – Introduction to CCST Networking Certification

OSPF Multi-Area Configuration Lab

This lab article describes how to configure OSPFv2 multi-area using both interface method and global method. You will also learn how to configure passive interfaces, network type, and stub areas.

Lab Compatibility: Packet Tracer 8.2, GNS3, Cisco Modeling Labs

Cisco Certification: CCNA, CCNP

GNS3 Lab Topology (optional)

Lab Summary

  • Enable OSPF on router connected interfaces of R1, R2, R3, INET-1 with interface method.
  • Enable passive interfaces on LAN segments and loopback interfaces.
  • Enable OSPF on router connected interfaces of Remote-1, Remote-2 with global method.
  • Enable passive interfaces on LAN segments and loopback interfaces.
  • Configure OSPF point-to-point network type on all WAN interfaces assigned to area 0.
  • Configure Remote-1 and Remote-2 routers as OSPF stub areas.
  • Advertise all LAN segments, connected WAN subnets, and loopbacks interfaces.
  • Advertise a default route from INET-1 to all downstream neighbors for internet access.
  • Verify lab configuration and OSPF routing tables.

Download Packet Tracer lab file: ospf.pkt

Step 1:

Enable OSPF on router connected interfaces of R1, R2, R3, and INET-1 with interface configuration method. Configure passive interfaces on LAN segments and loopback interfaces. Advertise all LAN segments and loopback interfaces to neighbors.

R1

interface Loopback0
description Management Interface
ip address 192.168.255.1 255.255.255.255
ip ospf 1 area 0

interface GigabitEthernet0/0/0
description link to R2 router
ip address 192.168.1.2 255.255.255.252
ip ospf 1 area 1
no shut

interface GigabitEthernet0/0/1
description link to INET-1 router
ip address 192.168.1.9 255.255.255.252
ip ospf 1 area 0
no shut

interface GigabitEthernet0/0/2
description link to R3 router
ip address 192.168.1.5 255.255.255.252
ip ospf 1 area 0
no shut

router ospf 1
passive-interface Loopback0

R2

interface Loopback0
description Management Interface
ip address 192.168.255.2 255.255.255.255
ip ospf 1 area 1

interface GigabitEthernet0/0/0
description link to R1 router
ip address 192.168.1.1 255.255.255.252
ip ospf 1 area 1
no shut

interface GigabitEthernet0/0/1
description LAN (172.16.1.0/24)
ip address 172.16.1.254 255.255.255.0
ip ospf 1 area 1
no shut

router ospf 1
passive-interface default
no passive-interface GigabitEthernet0/0/0

R3

interface Loopback0
description Management Interface
ip address 192.168.255.3 255.255.255.255
ip ospf 1 area 0

interface GigabitEthernet0/0/0
description link to R1 router
ip address 192.168.1.6 255.255.255.252
ip ospf 1 area 0
no shut

interface GigabitEthernet0/0/1
description link to INET-1 router
ip address 192.168.1.13 255.255.255.252
ip ospf 1 area 0
no shut

interface GigabitEthernet0/0/2
description link to Remote-1
ip address 192.168.1.17 255.255.255.252
ip ospf 1 area 2
no shut

router ospf 1
passive-interface Loopback0

INET-1

interface Loopback0
description Management Interface
ip address 192.168.255.4 255.255.255.255
ip ospf 1 area 0

interface GigabitEthernet0/0
description link to R1 router
ip address 192.168.1.10 255.255.255.252
ip ospf 1 area 0
no shut

interface GigabitEthernet1/0
description link to R3 router
ip address 192.168.1.14 255.255.255.252
ip ospf 1 area 0
no shut

interface GigabitEthernet2/0
description link to ISP router
ip address 172.33.1.1 255.255.255.252
no shut

interface GigabitEthernet3/0
description link to Remote-2 router
ip address 192.168.1.21 255.255.255.252
ip ospf 1 area 3
no shut

router ospf 1
passive-interface GigabitEthernet2/0
passive-interface Loopback0

Step 2:

Enable OSPF on router connected interfaces of Remote-1 and Remote-2 with global configuration method. Configure passive interfaces on LAN segments and loopback interfaces. Advertise all LAN segments and loopback interfaces to neighbors.

Remote-1

interface Loopback0
description Management Interface
ip address 192.168.255.5 255.255.255.255

interface GigabitEthernet1/0/1
description link to R3 router
no switchport
ip address 192.168.1.18 255.255.255.252
no shut

router ospf 1
passive-interface Loopback0
passive-interface Vlan10
passive-interface Vlan11
passive-interface Vlan12
network 172.16.0.0 0.0.255.255 area 2
network 192.168.1.16 0.0.0.3 area 2
network 192.168.255.5 0.0.0.0 area 2

Remote-2

interface Loopback0
description Management Interface
ip address 192.168.255.6 255.255.255.255

interface GigabitEthernet0/0/0
description link to INET-1 router
ip address 192.168.1.22 255.255.255.252
no shut

interface GigabitEthernet0/0/1
description LAN (172.16.2.0/26)
ip address 172.16.2.62 255.255.255.192
no shut

router ospf 1
passive-interface default
no passive-interface GigabitEthernet0/0/0
network 172.16.2.0 0.0.0.63 area 3
network 192.168.1.20 0.0.0.3 area 3
network 192.168.255.6 0.0.0.0 area 3

Step 3:

Configure OSPF point-to-point network type on all WAN interfaces assigned to area 0. This will prevent DR/BDR election and speed convergence for WAN links.

R1

interface GigabitEthernet0/0/1
ip ospf network point-to-point

interface GigabitEthernet0/0/2
ip ospf network point-to-point

R3

interface GigabitEthernet0/0/0
ip ospf network point-to-point

interface GigabitEthernet0/0/1
ip ospf network point-to-point

INET-1

interface GigabitEthernet0/0
ip ospf network point-to-point

interface GigabitEthernet1/0
ip ospf network point-to-point

Step 4:

Configure Remote-1 and Remote-2 routers as OSPF stub areas to reduce the size of OSPF link state database of routers.

Remote-1

router ospf 1
area 2 stub

R3

router ospf 1
area 2 stub

Remote-2

router ospf 1
area 3 stub

INET-1

router ospf 1
area 3 stub

Step 5:

Advertise a default route from INET-1 to all downstream neighbors for internet access.

INET-1

ip route 0.0.0.0 0.0.0.0 172.33.1.2
router ospf 1
default-information originate

Step 6:

Verify neighbor adjacencies, routing tables, network type, stub areas, and connectivity.

show ip ospf neighbor (R1, INET-1, R3)
show ip route (R1, INET-1, R3)
show ip protocols (R1)
show ip ospf interface brief (R1, INET-1, Remote-1)
show ip ospf interface (R1, INET-1, Remote-1)
ping 172.16.2.1 (LAN-2)
ping 172.33.1.2 (ISP)
ping 172.16.10.254 (Remote-1)
ping 172.16.11.254 (Remote-1)
ping 172.16.12.254 (Remote-1)

Cisco CCNP 350-401 Certification Labs (2024)